Temel Solaris Komutları

15 Mayıs 2011 Pazar

Bugünlerde çok yoğun olsamda Solaris ve Macintosh üzerinde yine  birşeyler yazacağım. Aşağıda Solaris için temel komutlar var.

Os hakkında bilgi alınabilecek komutlar,

1. cat /etc/release
2. showrev
3. uname -a

Fiziksel memory ile ilgili bilgi almak için

1. prtconf

Fiziksel/virtual cpu ile ilgili bilgi almak için

1. psrinfo
2. psrinfo -v (list virtual processors and info)
3. psrinfo -pv (list physical and accosiated virtual processors)

Cpu platform ilgili bilgi almak için

1. isainfo
2. isainfo -bv (more info about processor flags)
3. isalist (list feature of processors)

Sistem tarih ve saati ile ilgili işlemler

1. date (to reveal current timestamp)
2. date ‘+DateTime: %m.%d.%y @ %H.%M.%S’
3. date mmddHHMMccYY
i.e : date 050817252009 ( change system time to May 8 17:25:00 EDT 2009)

Sistem üzerinde çalışan prosesler ile ilgili bilgi almak

1. ps, ps -ef
2. pgrep (search process list for matching program i.e pgrep sshd)
3. pkill (searching matching program and kill them unless a different signal is sent : i.e ‘HUP’)
4. pwdx (list the working directory of specified process)
“The quieter you become, the more you are able to hear…” – BT

#!/bin/bash
for qw in `cert.txt`
do
echo “Certification passed: $qw”
done


Share/Bookmark

0 comments :